Mengenal IP Address

Mengenal IP Address, IP address adalah cara komputer berkomunikasi dengan komputer lain di jaringan. IP address bisa diibaratkan seperti ‘alamat rumah’ untuk komputer. Karena digunakan sebagai pengenal komputer yang satu dengan yang lain maka IP address tidak boleh sama. IP address yang masih digunakan saat ini adalah IP versi 4 (32 bit) dan yang akan banyak digunakan di masa depan adalah IP versi 6 (128 bit).

Mengenal IP Address

Bentuk penulisan IPv4 dituliskan dalam 4 kelompok bilangan yaitu 255.255.255.255 atau kalau dibinerkan menjadi 11111111.11111111.11111111.11111111, format tersebut dibagi menjadi dua bagian yaitu Network ID dan Host ID. Network ID menunjukkan alamat dari jaringannya sedangkan Host ID menunjukkan banyaknya host. Bisa juga dikatakan Network ID adalah nama jalan sedangkan Host ID adalah nomor rumahnya.

IP versi 4 dibagi menjadi 5 kelas yaitu kelas A, B, C, D dan E. Untuk IP kelas D dan E digunakan untuk kepentingan khusus seperti multicasting. Jadi yang digunakan secara umum adalah IP kelas A, B, dan C. Berikut ini pembagiannya.

Kelas A Kelas B Kelas C Kelas DKelas E
Range 0-127 128-191 192-233 224-247 248-255
Oktet Pertama 0 10 110 1110 1111
Panjang Network ID w w.x w.x.y - -
Panjang Host ID x.y.z y.z z - -
Network Prefix 8 16 24 - -
Network Maksimum 127 16348 2097152 - -
Host Maksimum 16777214 65534 254 - -

Contoh :
IP 192.168.0.15 adalah IP kelas C dengan :
Network ID = 192.168.0.0
Host ID = 192.168.0.15
Subnet Mask = 255.255.255.0

Subnet mask digunakan untuk membaca dan memastikan bahwa komputer yang terhubung berada dalam kelas yang sama. Jadi selain komputer diberi alamat IP juga perlu diberikan subnet mask supaya dapat bekerja di jaringan. Berikut ini subnet mask yang digunakan masing masing kelas.

Kelas Subnet Mask
A 255.0.0.0
B 255.255.0.0
C 255.255.255.0

IP Address Versi 6 (ipv6)
IP versi 6 ini muncul karena derasnya penggunaan ip versi 4 sehingga akhirnya para jago 2 internet memutuskan untuk membuat pengalamatan yg lebih efisien sehingga muncul yg namanya ip versi 6 ini. Berikut ini adalah contoh format alamat IPv6 :
21DA:00D3:0000:2F3B:02AA:00FF:FE28:9C5A atau bisa juga desederhanakan menjadi: 21DA3:0:2F3B:2AA:FF:FE28:9C5A

Netmask
Netmask (subnetting) ini merupakan mask yang membagi alamat ip menjadi subnet subnet (menentukan range alamat ip ). Netmask ini terdiri dari 4 byte dengan
format mirip ip address versi 4. di mana tiap byte netmask yang dipisahkan titik, mewakili range dari ip address , misal:

Jika netmask: 255.255.255.0 maka range ip addressnya ya semua alamat ip yang memiliki 3 byte pertama yg sama dg ip address dari mesin dengan netmask 255.255.255.0 ( 3 byte pertama netmask adalah 255.255.255 ). Misal komputer dg alamat ip 192.168.1.10 maka rangenya 192.168.1.0-192.168.192.168.1.255

Untuk lebih jelasnya Pembagian Kelas IP Address dan Subnetting dapat diunduh DISINI
More »

DNS Cache Dengan DnsSpeeder



DNS Cache Dengan DnsSpeeder, sebenarnya program ini tidak terlalu jauh berbeda dengan simple dns plus. Bedanya program ini freeware alias gratis, bebas dari virus, dan yang lebih keren lagi program ini sangat ringan (tidak membebani kinerja komputer). Tentu saja untuk professional pasti akan lebih memilih simple DNS plus karena fiturnya lebih lengkap, Namun kalau melihat kebutuhan home user kebanyakan hanya membutuhkan DNS cache untuk itu saya sarankan menggunakan program DnsSpeeder ini yang berguna mempercepat response time dibanding kita menggunakan DNS yang jaraknya lumayan jauh dan terkadang tidak terjangkau network kita sendiri. Bukan mempercepat dalam artian.


Pada saat kita browsing di internet tanpa kita sadari sebenarnya kita melakukan proses “meminta”, yaitu meminta informasi nomor ip alamat website yang kita tuju lalu kemudian informasi ini dikirimkan kembali ke komputer kita lalu kita menuju ke website tersebut dengan informasi yang diberikan oleh DNS server. Dalam proses nyata banyak sekali hambatan yang bisa membuat proses “meminta” ini terganggu. Antara lain misalnya: Jarak DNS server dengan kita terlalu jauh atau mungkin bahkan tidak terjangkau oleh jaringan kita, Kemampuan DNS server terlalu lemah akibat banyak dipakai oleh orang banyak. Dengan membangun DNS cache kita akan melakukan bypass prosedur ini yang hasilnya nantinya akan memberikan response yang lebih cepat dan tentunya akan mempercepat kegiatan internet kita.


Program ini bisa digabung dengan squid cukup dengan memberikan parameter dns_nameserver 127.0.01 pada squid.conf , dapat juga diaplikasikan pada jaringan LAN atau jaringan WAN yang mendukung. Sangat disarankan untuk pengguna rumahan atau pengguna yang ISP-nya pelit bin lemot… :D

Download :



[Via]
More »

Daftar Port Pada Komputer

Salah satu penyebab suatu sistem komputer bisa ditembus dari luar adalah karena adanya port yang terbuka, pada artikel kali ini membahas tentang Daftar Port Pada Komputer.

Berikut lengkapnya:

Dibawah ini merupakan daftar port -port yang ada dikomputer Anda beserta nama dari port tersebut.


Port Application Status

1/TCP,UDP TCP Port Service Multiplexer Official
2/TCP,UDP Management Utility Official
3/TCP,UDP Compression Process Official
5/TCP,UDP Remote Job Entry Official
7/TCP,UDP Echo Official
9/TCP,UDP Discard Official
11/TCP,UDP Active Users Official
13/TCP,UDP DAYTIME - (RFC 867) Official
17/TCP,UDP Quote of the Day Official
18/TCP,UDP Message Send Protocol Official
19/TCP,UDP Character Generator Official
20/TCP FTP - data Official
21/TCP FTP—control (command) Official
22/TCP,UDP Secure Shell (SSH)—used for secure logins, file transfers (scp, sftp) and port forwarding Official
23/TCP Telnet protocol—unencrypted text communications Official
25/TCP Simple Mail Transfer Protocol (SMTP)—used for e-mail routing between mail servers Official
26/TCP,UDP RSFTP—a simple FTP-like protocol Unofficial
35/TCP,UDP Any private printer server protocol Official
35/TCP,UDP QMS Magicolor 2 printer server protocol Unofficial
37/TCP,UDP TIME protocol Official
39/TCP,UDP Resource Location Protocol[3] (RLP)—used for determining the location of higher level services from hosts on a network Official
41/TCP,UDP Graphics Official
42/TCP,UDP nameserver, ARPA Host Name Server Protocol Official
42/TCP,UDP WINS Unofficial
43/TCP WHOIS protocol Official
49/TCP,UDP TACACS Login Host protocol Official
52/TCP,UDP XNS (Xerox Network Services) Time Protocol Official
53/TCP,UDP Domain Name System (DNS) Official
54/TCP,UDP XNS (Xerox Network Services) Clearinghouse Official
56/TCP,UDP XNS (Xerox Network Services) Authentication Official
56/TCP,UDP RAP (Route Access Protocol)[4] Unofficial
57/TCP MTP, Mail Transfer Protocol Unofficial
58/TCP,UDP XNS (Xerox Network Services) Mail Official
67/UDP Bootstrap Protocol (BOOTP) Server; also used by Dynamic Host Configuration Protocol (DHCP) Official
68/UDP Bootstrap Protocol (BOOTP) Client; also used by Dynamic Host Configuration Protocol (DHCP) Official
69/UDP Trivial File Transfer Protocol (TFTP) Official
70/TCP Gopher protocol Official
79/TCP Finger protocol Official
80/TCP Hypertext Transfer Protocol (HTTP) Official
81/TCP Torpark—Onion routing Unofficial
82/UDP Torpark—Control Unofficial
83/TCP MIT ML Device Official
88/TCP Kerberos—authentication system Official
90/TCP,UDP dnsix (DoD Network Security for Information Exchange) Securit Attribute Token Map Official
90/TCP,UDP Pointcast Unofficial
101/TCP NIC host name Official
102/TCP ISO-TSAP (Transport Service Access Point) Class 0 protocol[5] Official
104/TCP,UDP ACR/NEMA Digital Imaging and Communications in Medicine Official
107/TCP Remote TELNET Service[6] protocol Official109/TCP Post Office Protocol 2 (POP2) Official110/TCP Post Office Protocol 3 (POP3) Official
111/TCP,UDP Sun Remote Procedure Call Official
113/TCP ident—old user identification system, still used by IRC servers to identify users Official
113/TCP,UDP Authentication Service (auth) Official
115/TCP Simple File Transfer Protocol (SFTP) Official
117/TCP UUCP Path Service Official
118/TCP,UDP SQL (Structured Query Language) Services Official
119/TCP Network News Transfer Protocol (NNTP)—used for retrieving newsgroup messages Official
123/UDP Network Time Protocol (NTP)—used for time synchronization Official
135/TCP,UDP DCE endpoint resolution Official
135/TCP,UDP Microsoft EPMAP (End Point Mapper), also known as DCE/RPC Locator service[7], used to remotely manage services including DHCP server, DNS server and WINS Unofficial
137/TCP,UDP NetBIOS NetBIOS Name Service Official1
38/TCP,UDP NetBIOS NetBIOS Datagram Service Official
139/TCP,UDP NetBIOS NetBIOS Session Service Official
143/TCP,UDP Internet Message Access Protocol (IMAP)—used for retrieving, organizing, and synchronizing e-mail messages
153/TCP,UDP SGMP, Simple Gateway Monitoring Protocol Official
156/TCP,UDP SQL Service Official
158/TCP,UDP DMSP, Distributed Mail Service Protocol Unofficial
161/TCP,UDP Simple Network Management Protocol (SNMP) Official
162/TCP,UDP Simple Network Management Protocol Trap (SNMPTRAP)[9] Official
170/TCP Print-srv, Network PostScript Official
177/TCP,UDP X Display Manager Control Protocol (XDMCP) Official
179/TCP BGP (Border Gateway Protocol) Official
194/TCP IRC (Internet Relay Chat) Official
201/TCP,UDP AppleTalk Routing Maintenance Official
209/TCP,UDP The Quick Mail Transfer Protocol Official
213/TCP,UDP IPX Official
218/TCP,UDP MPP, Message Posting Protocol Official
220/TCP,UDP IMAP, Interactive Mail Access Protocol, version 3 Official
259/TCP,UDP ESRO, Efficient Short Remote Operations Official
264/TCP,UDP BGMP, Border Gateway Multicast Protocol Official
311/TCP Mac OS X Server Admin (officially AppleShare IP Web admistration) Official
308/TCP Novastor Online Backup Official
318/TCP,UDP PKIX TSP, Time Stamp Protocol Official
323/TCP,UDP IMMP, Internet Message Mapping Protocol Unofficial
366/TCP,UDP ODMR, On-Demand Mail Relay Official
369/TCP,UDP Rpc2portmap Official
371/TCP,UDP ClearCase albd Official
383/TCP,UDP HP data alarm manager Official
384/TCP,UDP A Remote Network Server System Official
387/TCP,UDP AURP, AppleTalk Update-based Routing Protocol Official
389/TCP,UDP Lightweight Directory Access Protocol (LDAP) Official
401/TCP,UDP UPS Uninterruptible Power Supply Official
402/TCP Altiris, Altiris Deployment Client Unofficial
411/TCP Direct Connect Hub Unofficial
412/TCP Direct Connect Client-to-Client Unofficial
427/TCP,UDP Service Location Protocol (SLP) Official
443/TCP Hypertext Transfer Protocol over TLS/SSL (HTTPS) Official
444/TCP,UDP SNPP, Simple Network Paging Protocol (RFC 1568) Official
445/TCP Microsoft-DS Active Directory, Windows shares Official
445/UDP Microsoft-DS SMB file sharing Official
464/TCP,UDP Kerberos Change/Set password Official
465/TCP Cisco protocol Unofficial
465/TCP SMTP over SSL Unofficial
475/TCP tcpnethaspsrv (Hasp services, TCP/IP version) Official
497/TCP Dantz Retrospect Official
500/UDP Internet Security Association and Key Management Protocol (ISAKMP) Official
502/TCP,UDP Modbus, Protocol Unofficial
512/TCP Rexec, Remote Process Execution Official
512/UDP comsat, together with biff Official
513/TCP Login Official
513/UDP Who Official
514/TCP Shell—used to execute non-interactive commands on a remote system Official
514/UDP Syslog—used for system logging Official
515/TCP Line Printer Daemon—print service Official
517/UDP Talk Official
518/UDP NTalk Official
520/TCP efs, extended file name server Official
520/UDP Routing—RIP Official
524/TCP,UDP NCP (NetWare Core Protocol) is used for a variety things such as access to primary NetWare server resources, Time Synchronization, etc. Official
525/UDP Timed, Timeserver Official
530/TCP,UDP RPC Official
531/TCP,UDP AOL Instant Messenger, IRC Unofficial
532/TCP netnews Official
533/UDP netwall, For Emergency Broadcasts Official
540/TCP UUCP (Unix-to-Unix Copy Protocol) Official
542/TCP,UDP commerce (Commerce Applications) Official
543/TCP klogin, Kerberos login Official
544/TCP kshell, Kerberos Remote shell Official
546/TCP,UDP DHCPv6 client Official
547/TCP,UDP DHCPv6 server Official
548/TCP Apple Filing Protocol (AFP) over TCP Official
550/UDP new-rwho, new-who
556/TCP Remotefs, RFS, rfs_server Official
560/UDP rmonitor, Remote Monitor Official
561/UDP monitor Official
563/TCP,UDP NNTP protocol over TLS/SSL (NNTPS) Official
587/TCP e-mail message submission[10] (SMTP) Official
591/TCP FileMaker 6.0 (and later) Web Sharing (HTTP Alternate, also see port 80) Official
593/TCP,UDP HTTP RPC Ep Map, Remote procedure call over Hypertext Transfer Protocol, often used by Distributed Component Object Model services and Microsoft Exchange Server Official
604/TCP TUNNEL profile[11], a protocol for BEEP peers to form an application layer tunnel Official
623/UDP ASF Remote Management and Control Protocol (ASF-RMCP) Official
631/TCP,UDP Internet Printing Protocol (IPP) Official
636/TCP,UDP Lightweight Directory Access Protocol over TLS/SSL (LDAPS) Official
639/TCP,UDP MSDP, Multicast Source Discovery Protocol Official
646/TCP,UDP LDP, Label Distribution Protocol, a routing protocol used in MPLS networks Official
647/TCP DHCP Failover protocol[12] Official
648/TCP RRP (Registry Registrar Protocol)[13] Official
652/TCP DTCP, Dynamic Tunnel Configuration Protocol Unofficial
654/TCP AODV (Ad-hoc On-demand Distance Vector) Official
655/TCP IEEE MMS (IEEE Media Management System)[14][15] Official
657/TCP,UDP IBM RMC (Remote monitoring and Control) protocol, used by System p5 AIX Integrated Virtualization Manager (IVM)[16] and Hardware Management Console to connect managed logical partitions (LPAR) to enable dynamic partition reconfiguration Official
660/TCP Mac OS X Server administration Official
665/TCP sun-dr, Remote Dynamic Reconfiguration
674/TCP ACAP (Application Configuration Access Protocol) Official
691/TCP MS Exchange Routing Official
692/TCP Hyperwave-ISP Official
694/UDP Linux-HA High availability Heartbeat Unofficial
695/TCP IEEE-MMS-SSL (IEEE Media Management System over SSL)[17] Official
698/UDP OLSR (Optimized Link State Routing) Official
699/TCP Access Network Official
700/TCP EPP (Extensible Provisioning Protocol), a protocol for communication between domain name registries and registrars (RFC 4934) Official
701/TCP LMP (Link Management Protocol (Internet))[18], a protocol that runs between a pair of nodes and is used to manage traffic engineering (TE) links Official
702/TCP IRIS[19][20] (Internet Registry Information Service) over BEEP (Blocks Extensible Exchange Protocol)[21] (RFC 3983) Official
706/TCP SILC, Secure Internet Live Conferencing Official
711/TCP Cisco TDP, Tag Distribution Protocol[22][23][24]—being replaced by the MPLS Label Distribution Protocol[25] Official
712/TCP TBRPF, Topology Broadcast based on Reverse-Path Forwarding routing protocol (RFC 3684) Official
712/UDP Promise RAID Controller Unofficial
720/TCP SMQP, Simple Message Queue Protocol Unofficial
749/TCP,UDP Kerberos administration Official
750/TCP rfile Official
750/UDP loadav Official
750/UDP kerberos-iv, Kerberos version IV Official
751/TCP,UDP pump Official
751/TCP,UDP kerberos_master, Kerberos authentication Unofficial
752/TCP qrh Official
752/UDP qrh Official
752/UDP userreg_server, Kerberos Password (kpasswd) server Unofficial
753/TCP Reverse Routing Header (rrh)[26] Official
753/UDP Reverse Routing Header (rrh) Official
753/UDP passwd_server, Kerberos userreg server Unofficial
754/TCP tell send Official
754/TCP krb5_prop, Kerberos v5 slave propagation Unofficial
754/UDP tell send Official
760/TCP,UDP ns Official
760/TCP,UDP krbupdate [kreg], Kerberos registration Unofficial
782/TCP Conserver serial-console management server Unofficial
783/TCP SpamAssassin spamd daemon Unofficial
829/TCP CMP (Certificate Management Protocol) Unofficial
860/TCP iSCSI (RFC 3720) Official
873/TCP rsync file synchronisation protocol Official
888/TCP cddbp, CD DataBase (CDDB) protocol (CDDBP)—unassigned but widespread use Unofficial
901/TCP Samba Web Administration Tool (SWAT) Unofficial
901/TCP, UDP VMware Virtual Infrastructure Client (UDP from server being managed to management console) Unofficial
902/TCP VMware Server Console (TCP from management console to server being Managed)[27] Unofficia
l904/TCP VMware Server Alternate (if 902 is in use, i.e. SUSE linux) Unofficial
911/TCP Network Console on Acid (NCA)—local tty redirection over OpenSSH Unofficial
953/TCP,UDP Domain Name System (DNS) RDNC Service Official
981/TCP SofaWare Technologies Remote HTTPS management for firewall devices running embedded Check Point FireWall-1 software Unofficial
989/TCP,UDP FTPS Protocol (data): FTP over TLS/SSL Official
990/TCP,UDP FTPS Protocol (control): FTP over TLS/SSL Official
991/TCP,UDP NAS (Netnews Administration System) Official
992/TCP,UDP TELNET protocol over TLS/SSL Official
993/TCP Internet Message Access Protocol over SSL (IMAPS) Official
995/TCP Post Office Protocol 3 over TLS/SSL (POP3S) Official
1023/TCP,UDP Reserved[1]


Misalnya browsing menggunakan Port 80 (HTTP kan?) Semoga bermanfaat tentang Daftar Port Pada Komputer diatas..
More »

Cara Sharing Internet Smart



Pada postingan kali ini saya ingin membahas tentang share koneksi internet smart dengan komputer yang menggunakan LAN (peer to peer).

Berikut ilustrasi koneksi yang akan kita buat :



Langkah Pertama (Komputer 1) :

1. Masuk ke command Line tekan tombol windows R lalu ketikan cmd lalu ipconfig/all.
2. Setleah itu catat DNS server modem anda.





Langkah Kedua (Komputer 1) :

1. matikan dulu koneksi smart-nya .
2. masuk ke control panel - network and internet connections - network connection - smart telecom - properties - advance pada Internet Connection Sharing
3. contreng Allow other network user to connect through this computer’s Internet Connection



4. kemudian pilih jenis koneksi dengan komputer/laptop yang lain, bisa menggunakan Local Area Connection bila koneksi via kabel utp atau pilih Wireless Network Connection bila koneksi via wifi/wlan
5. klik OK, maka setelah itu IP pada koneksi yang anda pilih akan diubah menjadi 192.168.0.1


Langkah Ketiga (Komputer 2) :

1. control panel - network and internet connections - network connection - local area connection - properties
2. Internet Protocol (TCP/IP) - Properties
3. tentukan IP, Gateway, DNS pada computer 2 yaitu ip addressnya 192.168.0.2, subnetmasknya 255.255.255.0 gateway 192.168.0.1 dan DNS Servernya seperti yang sudah kita catat tadi.


Langkah Keempat

1. koneksikan/pasang kabel utp-nya (crossover) antara komputer 1 dan komputer 2
2. aktifkan koneksi internet smart-nya atau koneksi yang lainnya (jika anda menggunakan selain smart )
3. Sekarang coba anda browsing pada komputer 2, apabila belum bisa dipakai maka cek pada setting IP dan Default Gatewaynya.

Semoga bermanfaat.....
More »